Static Caravan Owners Advice Forum | Sales | Rental | Sublet

 

About Supporting Members FUP (Please Read) The GoStatic Reference Hub
Go Back   Static Caravan Owners Advice Forum | Sales | Rental | Sublet > GoStatic University > Owning A Caravan > Technical Issues

Technical Issues A place to ask and/or give advice on technical issues

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 24-08-2019, 16:00
GeoffG16 GeoffG16 is offline
Junior Member
 
Join Date: Aug 2019
Posts: 2
Default Toilet not flushing properly

Both conventional toilets in my Atlas Platinum have the same problem - the water entering the bowl when flushing cleans only about 2/3 of the bowl resulting in the front 1/3 not being washed. The volume of water in the cistern is correct and I can't feel any restriction under the rim. Has anyone else experienced this? Can anyone suggest a cause/remedy? Thanks.
Reply With Quote

  #2  
Old 24-08-2019, 19:31
slattster slattster is offline
Senior Member
 
Join Date: Aug 2014
Posts: 408
Default

Hello Geoff , yes I have same problem , had parts replaced and works for couple of flushes then reverts back to problem, solution I found was unscrewing flush button till it was just loose and then it would flush correctly , I then put a rubber O ring under buttons so it wouldn’t spin around when pressed .
Reply With Quote
  #3  
Old 28-08-2019, 11:21
GeoffG16 GeoffG16 is offline
Junior Member
 
Join Date: Aug 2019
Posts: 2
Default

Thanks for the suggestion! I have handle flushes on both systems but will experiment next time I'm onsite.
Reply With Quote
  #4  
Old 28-08-2019, 15:56
slattster slattster is offline
Senior Member
 
Join Date: Aug 2014
Posts: 408
Default

Mine are buttons on top of cistern lid , if I removed the cistern lid and flushed it then it would work ok every time so try disconnecting handle and then flush it see if it works.
Reply With Quote
Reply

Bookmarks

Tags
flushing, problem, toilet

West Coast Windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Toilet question GFM Technical Issues 8 11-05-2018 10:55
Toilet seal ROSEDALE Technical Issues 6 26-04-2012 18:32
Toilet & Sink fear345 Technical Issues 7 20-10-2011 22:13
toilet flush jlavery555 Technical Issues 3 11-10-2011 19:38
broken toilet pan stephen p Owning A Caravan 5 07-01-2011 20:38


All times are GMT. The time now is 01:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.